<!doctype html>
<html lang="en-US" itemscope itemtype="http://schema.org/WebPage">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">

	<title>Herbicide eases milfoil’s stranglehold on Lake Iroquois &#8211; Williston Observer</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Williston Observer &raquo; Feed" href="https://www.willistonobserver.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Williston Observer &raquo; Comments Feed" href="https://www.willistonobserver.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Williston Observer &raquo; Herbicide eases milfoil’s stranglehold on Lake Iroquois Comments Feed" href="https://www.willistonobserver.com/herbicide-eases-milfoils-stranglehold-on-lake-iroquois/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.willistonobserver.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- willistonobserver.com is managing ads with Advanced Ads 1.25.1 – https://wpadvancedads.com/ --><script>
			advanced_ads_ready=function(){var e,t=[],n="object"==typeof document&&document,d=n&&n.documentElement.doScroll,o="DOMContentLoaded",a=n&&(d?/^loaded|^c/:/^loaded|^i|^c/).test(n.readyState);return!a&&n&&(e=function(){for(n.removeEventListener(o,e),window.removeEventListener("load",e),a=1;e=t.shift();)e()},n.addEventListener(o,e),window.addEventListener("load",e)),function(e){a?setTimeout(e,0):t.push(e)}}();		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.willistonobserver.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='vmagazine-google-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%2C400italic%2C300%7CPoppins%3A300%2C400%2C500%2C600%2C700%7CMontserrat%3A300%2C300i%2C400%2C800%2C800i%7CLato%3A300%2C400%2C700%2C900&#038;ver=5.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='scrollbar-style-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/mCustomScrollbar/jquery.mCustomScrollbar.min.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='elegant-fonts-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/elegant_font/HTML-CSS/style.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='lightslider-style-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/lightslider/lightslider.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-style-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/font-awesome/css/font-awesome.min.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/css/animate.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-style-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/prettyPhoto/css/prettyPhoto.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='slick-style-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/slick/slick.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='slick-style1-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/slick/slick-theme.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='vmagazine-keyboard-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/css/keyboard.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='vmagazine-style-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/style.css?ver=1.1.8' type='text/css' media='all' />
<style id='vmagazine-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='vmagazine-responsive-css'  href='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/css/responsive.css?ver=1.1.8' type='text/css' media='all' />
<link rel='stylesheet' id='vmagazine-typhography-font-css'  href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.7.3' type='text/css' media='all' />
<script type='text/javascript' src='https://www.willistonobserver.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.25.1' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.1' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.11.0' id='advanced-ds-pro/front-js'></script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.willistonobserver.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.11.0' id='advanced-ads-pro/cache_busting-js'></script>
<link rel="https://api.w.org/" href="https://www.willistonobserver.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.willistonobserver.com/wp-json/wp/v2/posts/52954" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.willistonobserver.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.willistonobserver.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.3" />
<link rel="canonical" href="https://www.willistonobserver.com/herbicide-eases-milfoils-stranglehold-on-lake-iroquois/" />
<link rel='shortlink' href='https://www.willistonobserver.com/?p=52954' />
<link rel="alternate" type="application/json+oembed" href="https://www.willistonobserver.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.willistonobserver.com%2Fherbicide-eases-milfoils-stranglehold-on-lake-iroquois%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.willistonobserver.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.willistonobserver.com%2Fherbicide-eases-milfoils-stranglehold-on-lake-iroquois%2F&#038;format=xml" />

		<!-- GA Google Analytics @ https://m0n.co/ga -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-5220112-1', 'auto');
			ga('send', 'pageview');
		</script>

	<script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
		<link rel="pingback" href="https://www.willistonobserver.com/xmlrpc.php">		<style type="text/css">
					.site-title,
			.site-description {
				position: absolute;
				clip: rect(1px, 1px, 1px, 1px);
			}
				</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #f4f4f4; }
</style>
	<link rel="icon" href="https://www.willistonobserver.com/wp-content/uploads/2020/05/K36Ujrpe_400x400-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://www.willistonobserver.com/wp-content/uploads/2020/05/K36Ujrpe_400x400-300x300.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.willistonobserver.com/wp-content/uploads/2020/05/K36Ujrpe_400x400-300x300.jpg" />
<meta name="msapplication-TileImage" content="https://www.willistonobserver.com/wp-content/uploads/2020/05/K36Ujrpe_400x400-300x300.jpg" />
		<style type="text/css" id="wp-custom-css">
			#comments,
#respond {
    display: none;
}
/* HEADER */
.site-branding {
	width:33%;
}
.site-branding img {
	width:100%;
}
.header-ad-wrapper {
	width:66%;
}
.header-ad-wrapper a {
	float:right;
}
/* NAVIGATION */
li.btn-menu {
    background-color: #971111;
    float: right;
    text-align: center;
    padding-bottom: 0 !important;
}
li.btn-menu a {
    color: #fff !important;
    padding: 1rem !important;
}
.menu-mmnu-container {
	/*width:95%;*/
}
/* MOBILE NAV */
.vmagazine-mobile-navigation-wrapper .mobile-navigation .site-branding a.custom-logo-link {
    max-width: 100%;
}
.vmagazine-mobile-nav-wrapp .vmagazine-logo {
    width: 50%;
}
.vmagazine-mobile-nav-wrapp .mob-search-icon,
.vmagazine-mobile-nav-wrapp .nav-toggle {
    width: 25%;
}
.vmagazine-mob-outer,
.vmagazine-mob-outer.menu-fixed-triggered.menu-fixed {
    background: #fff;
}
.vmagazine-mobile-nav-wrapp .mob-search-icon span {
    color: #000;
}
.vmagazine-mobile-nav-wrapp .nav-toggle span,
.vmagazine-mobile-nav-wrapp .nav-toggle span:before,
.vmagazine-mobile-nav-wrapp .nav-toggle span:after {
    background: #000;
}
.vmagazine-mobile-navigation-wrapper .mobile-navigation .nav-close span:before,
.vmagazine-mobile-navigation-wrapper .mobile-navigation .nav-close span:after/*,
.vmagazine-mobile-search-wrapper .mob-search-form .nav-close span:before,
.vmagazine-mobile-search-wrapper .mob-search-form .nav-close span:after*/ {
    border-top: 2px solid #000;
}
.vmagazine-mobile-navigation-wrapper .mobile-navigation .img-overlay {
    display: none;
}


/* Mobile Search 
.vmagazine-mobile-search-wrapper .mob-search-form .mob-search-wrapp .search-form input.search-field,
.vmagazine-mobile-search-wrapper .mob-search-form .mob-search-wrapp .search-form:after {
    color:#000;
}
.vmagazine-mobile-search-wrapper .mob-search-form .mob-search-wrapp .search-form label:before,
.vmagazine-mobile-search-wrapper .mob-search-form.focus .mob-search-wrapp .search-form label:before {
    background: #000;
}*/

/* ADS */
.willi-single-mobile {
    border-top: 1px solid #ccc;
    border-bottom: 1px solid #ccc;
    padding: 20px 0;
    margin-bottom: 30px;
}
.willi-middle-mobile-home,
.willi-top-mobile,
.willi-3rd-home-mobile,
.willi-7th-home-mobile,
.willi-9th-home-mobile {
    clear: both;
    padding-bottom: 20px;
    margin-bottom: 20px;
    border-bottom: 1px solid #ddd;
}
img {
	image-rendering: -webkit-optimize-contrast;
}


@media screen and (max-width: 1200px) {
    .site-branding a img.custom-logo {
        max-width: inherit;
    }
    .vmagazine-mobile-nav-wrapp .vmagazine-logo img {
        max-height: inherit;
    }
}

@media screen and (max-width: 768px) {
    .vmagazine-nav-wrapper nav.main-navigation .menu-mmnu-container ul.vmagazine_mega_menu li.menu-item a {
        color: #000;
    }
}
		</style>
		</head>

<body class="post-template-default single single-post postid-52954 single-format-standard custom-background wp-custom-logo vmagazineprotg group-blog cat-style-1 hover-effect-1 elements-paddings-hidden fullwidth_layout right-sidebar template-one vmagazine-single-layout aa-prefix-willi-">



	            <a class="skip-link screen-reader-text" href="#site-navigation">Skip to navigation</a>
            <a class="skip-link screen-reader-text" href="#main">Skip to content</a>
            
    <div class="vmagazine-mobile-search-wrapper">
        <div class="mob-search-form">
                         <div class="img-overlay"></div>
           
            <div class="mob-srch-wrap">
                <div class="nav-close">
                    <span></span>
                    <span></span>
                </div>
                <div class="mob-search-wrapp">
                    
<form method="get" class="search-form" action="https://www.willistonobserver.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" autocomplete="off" class="search-field" placeholder="Search ..." value="" name="s">
	</label>
	<input type="submit" class="search-submit" value="Search">

</form>

                    <div class="search-content"></div>
                    <div class="block-loader" style="display:none;">
                        <div class="sampleContainer">
                            <div class="loader">
                                <span class="dot dot_1"></span>
                                <span class="dot dot_2"></span>
                                <span class="dot dot_3"></span>
                                <span class="dot dot_4"></span>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>

<div class="vmagazine-mobile-navigation-wrapper">
 
    <div class="mobile-navigation">
                    <div class="img-overlay"></div>
        
        <div class="vmag-opt-wrap">
            <div class="nav-close">
                <span></span>
                <span></span>
            </div>

            <div class="icon-wrapper">
                	    <ul class="social">
	    			</ul>									
	                </div>
            <div class="site-branding">                 
                <a href="https://www.willistonobserver.com/" class="custom-logo-link" rel="home"><img width="420" height="80" src="https://www.willistonobserver.com/wp-content/uploads/2020/05/logo.png" class="custom-logo" alt="Williston Observer logo" srcset="https://www.willistonobserver.com/wp-content/uploads/2020/05/logo.png 420w, https://www.willistonobserver.com/wp-content/uploads/2020/05/logo-300x57.png 300w" sizes="(max-width: 420px) 100vw, 420px" /></a>                <div class="site-title-wrapper">
                                            <p class="site-title"><a href="https://www.willistonobserver.com/" rel="home">Williston Observer</a></p>
                                            <p class="site-description">Williston Vermont News and Events</p>
                                    </div>
            </div><!-- .site-branding -->
            	<div class="vmagazine-nav-wrapper">
		<div class="vmagazine-container">			
			<nav class="main-navigation clearfix" >
				<div class="nav-wrapper">
					
		                    <div class="index-icon">
            <a href="https://www.willistonobserver.com/"><i class="fa fa-home"></i></a>
        </div>
    					<div class="menu-mmnu-container"><ul id="primary-menu" class="menu vmagazine_mega_menu"><li id="menu-item-51560" class="menu-item menu-item-type-taxonomy menu-item-object-category page_item page-item-51560 no-mega-menu"><a href="https://www.willistonobserver.com/category/archive/">Previous Editions</a></li>
<li id="menu-item-51675" class="menu-item menu-item-type-post_type menu-item-object-page page_item page-item-51675 no-mega-menu"><a href="https://www.willistonobserver.com/williston-community-guide/">Williston Community Guide</a></li>
<li id="menu-item-51390" class="btn-menu menu-item menu-item-type-post_type menu-item-object-page page_item page-item-51390 no-mega-menu"><a href="https://www.willistonobserver.com/digital-edition/">Digital Edition</a></li>
</ul></div>				</div><!-- .nav-wrapper -->
			</nav><!-- #site-navigation -->

			
		</div><!-- .vmagazine-container -->	
	</div>
	    
        </div>
    </div>
</div>
	 <div class="vmagazine-main-wrapper">
		 
		     <div class="vmagazine-mob-outer">
        <div class="vmagazine-mobile-nav-wrapp">
            <div class="mob-search-icon">
                <span>
                    <i class="fa fa-search" aria-hidden="true"></i>
                </span>
             </div>
             <div class="vmagazine-logo">
                <a href="https://www.willistonobserver.com/" class="custom-logo-link" rel="home"><img width="420" height="80" src="https://www.willistonobserver.com/wp-content/uploads/2020/05/logo.png" class="custom-logo" alt="Williston Observer logo" srcset="https://www.willistonobserver.com/wp-content/uploads/2020/05/logo.png 420w, https://www.willistonobserver.com/wp-content/uploads/2020/05/logo-300x57.png 300w" sizes="(max-width: 420px) 100vw, 420px" /></a>             </div>
             <div class="nav-toggle">
                <div class="toggle-wrap">
                 <span></span>
                </div>
             </div>
        </div>
    </div>

		 <div class="vmagazine-header-handle">
		 		
<header id="masthead" class="site-header header-layout1 logo-shown">

	<div class="vmagazine-top-header menu-half">
		<div class="vmagazine-container">
			
			<div class="top-men-wrap">
				
				<div class="top-menu">
					<div class="top-men-wrapp"><ul id="top-menu" class="menu vmagazine_mega_menu"><li id="menu-item-46396" class="menu-item menu-item-type-post_type menu-item-object-page page_item page-item-46396 no-mega-menu"><a href="https://www.willistonobserver.com/williston-vermont-classifieds/">Classifieds</a></li>
<li id="menu-item-46395" class="menu-item menu-item-type-post_type menu-item-object-page page_item page-item-46395 no-mega-menu"><a href="https://www.willistonobserver.com/advertising/">Advertising</a></li>
<li id="menu-item-46397" class="menu-item menu-item-type-post_type menu-item-object-page page_item page-item-46397 no-mega-menu"><a href="https://www.willistonobserver.com/contact-williston-observer/">Contact Us</a></li>
<li id="menu-item-46400" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children page_item page-item-46400 no-mega-menu"><a href="https://www.willistonobserver.com/williston-information/">Town Information</a></li>
<li id="menu-item-46394" class="menu-item menu-item-type-post_type menu-item-object-page page_item page-item-46394 no-mega-menu"><a href="https://www.willistonobserver.com/about-us/">Contact Williston Observer</a></li>
</ul></div>				</div>
				
				
			</div>
						<div class="top-right">
									<div class="top-left">
							    <ul class="social">
	    			</ul>									
	    					</div>
													<div class="vmagazine-search-form-primary">
<form method="get" class="search-form" action="https://www.willistonobserver.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" autocomplete="off" class="search-field" placeholder="Search ..." value="" name="s">
	</label>
	<input type="submit" class="search-submit" value="Search">

</form>

</div>
					<div class="search-content"></div>
					<div class="block-loader" style="display:none;">
	            		<div class="sampleContainer">
						    <div class="loader">
						        <span class="dot dot_1"></span>
						        <span class="dot dot_2"></span>
						        <span class="dot dot_3"></span>
						        <span class="dot dot_4"></span>
						    </div>
						</div>
	        		</div>
							</div>	
				
		</div>
	</div><!-- .vmagazine-top-header -->
	

	<div class="logo-ad-wrapper">
		<div class="vmagazine-container">
			            <div class="site-branding">                 
                <a href="https://www.willistonobserver.com/" class="custom-logo-link" rel="home"><img width="420" height="80" src="https://www.willistonobserver.com/wp-content/uploads/2020/05/logo.png" class="custom-logo" alt="Williston Observer logo" srcset="https://www.willistonobserver.com/wp-content/uploads/2020/05/logo.png 420w, https://www.willistonobserver.com/wp-content/uploads/2020/05/logo-300x57.png 300w" sizes="(max-width: 420px) 100vw, 420px" /></a>                <div class="site-title-wrapper">
                                            <p class="site-title"><a href="https://www.willistonobserver.com/" rel="home">Williston Observer</a></p>
                                            <p class="site-description">Williston Vermont News and Events</p>
                                    </div>
            </div>
        						        	<div class="header-ad-wrapper">
		        				            </div><!-- .header-ad-wrapper -->
		            		</div><!-- .vmagazine-container -->
	</div><!-- .logo-ad-wrapper -->
    	<div class="vmagazine-nav-wrapper">
		<div class="vmagazine-container">			
			<nav id="site-navigation" class="main-navigation clearfix" >
				<div class="nav-wrapper">
					
		                    <div class="index-icon">
            <a href="https://www.willistonobserver.com/"><i class="fa fa-home"></i></a>
        </div>
    					<div class="menu-mmnu-container"><ul id="menu-main-menu" class="menu vmagazine_mega_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category page_item page-item-51560 no-mega-menu"><a href="https://www.willistonobserver.com/category/archive/">Previous Editions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page page_item page-item-51675 no-mega-menu"><a href="https://www.willistonobserver.com/williston-community-guide/">Williston Community Guide</a></li>
<li class="btn-menu menu-item menu-item-type-post_type menu-item-object-page page_item page-item-51390 no-mega-menu"><a href="https://www.willistonobserver.com/digital-edition/">Digital Edition</a></li>
</ul></div>				</div><!-- .nav-wrapper -->
			</nav><!-- #site-navigation -->

			
		</div><!-- .vmagazine-container -->	
	</div>
	   
            <div class="vmagazine-ticker-wrapper cS-hidden">
        <div class="vmagazine-container default-layout">
                        <div class="ticker-wrapp">
                    <div class="vmagazine-ticker-caption">
                        <span>Recent News</span>
                    </div>
                <ul id="vmagazine-news-ticker" >                    <li>
                        <div class="single-news">
                            <a href="https://www.willistonobserver.com/9-11-remembering-reflecting/">
                            9/11: Remembering, reflecting                            </a>
                            <span class="date">
                                September 9, 2021                            </span>
                        </div>
                    </li>
                            <li>
                        <div class="single-news">
                            <a href="https://www.willistonobserver.com/herbicide-eases-milfoils-stranglehold-on-lake-iroquois/">
                            Herbicide eases milfoil’s stranglehold on Lake Iroquois                            </a>
                            <span class="date">
                                September 9, 2021                            </span>
                        </div>
                    </li>
                            <li>
                        <div class="single-news">
                            <a href="https://www.willistonobserver.com/red-sox-honor-benevento-posthumously/">
                            Red Sox honor Benevento posthumously                            </a>
                            <span class="date">
                                September 9, 2021                            </span>
                        </div>
                    </li>
                            <li>
                        <div class="single-news">
                            <a href="https://www.willistonobserver.com/state-investigates-outbreak-tied-to-hockey-club/">
                            State investigates outbreak tied to hockey club                            </a>
                            <span class="date">
                                September 9, 2021                            </span>
                        </div>
                    </li>
                            <li>
                        <div class="single-news">
                            <a href="https://www.willistonobserver.com/guest-column-making-sense-of-the-pandemic-time-warp/">
                            Guest Column: Making sense of the pandemic time warp                            </a>
                            <span class="date">
                                September 9, 2021                            </span>
                        </div>
                    </li>
        </ul>            </div>
            </div><!--.vmagazine-container --></div></header><!-- #masthead -->
		</div>
		
		<div id="content" class="site-content">
			
				<div class="vmagazine-breadcrumb-wrapper ">
				
	<div class="vmagazine-bread-home">
			<div class="vmagazine-bread-wrapp vmagazine-container">
				
					<div class="breadcrumb-title">
											

											</div>
					<div class="vmagazine-breadcrumb"><nav role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs"><ul class="trail-items"><li class="trail-item trail-begin"><a href="https://www.willistonobserver.com" rel="home"><span>Home</span></a></li><li class="trail-item"><a href="https://www.willistonobserver.com/category/williston-vermont-news/"><span>News</span></a></li><li class="trail-item trail-end current"><span>Herbicide eases milfoil’s stranglehold on Lake Iroquois</span></li></ul></nav></div>			</div>
		</div>

			</div>	
		<div class="vmagazine-container container-wrapp-inner">
<div id="primary" class="content-area post-single-layout1 vmagazine-content">
	<main id="main" class="site-main" role="main">
		<article id="post-52954" class="post-52954 post type-post status-publish format-standard has-post-thumbnail hentry category-williston-vermont-news">
			
			<span class="cat-links"><a href="https://www.willistonobserver.com/category/williston-vermont-news/" class="cat-3" rel="category tag">News</a></span>
			<header class="entry-header">
				<h1 class="entry-title">Herbicide eases milfoil’s stranglehold on Lake Iroquois</h1>
			</header><!-- .entry-header -->

			<div class="entry-meta clearfix">
				<span class="posted-on"><i class="fa fa-clock-o"></i>September 9, 2021</span>			</div><!-- .entry-meta -->
			<div class="entry-thumb"><img width="1920" height="1000" src="https://www.willistonobserver.com/wp-content/uploads/2021/09/FRONT-Iroquois-1920x1000.jpg" class="attachment-vmagazine-single-large size-vmagazine-single-large wp-post-image" alt="View of Lake Iroquois from the shore" loading="lazy" /></div>
			<div class="entry-content clearfix">
				
<p>Lake Iroquois has seen a decrease in invasive milfoil this summer after an herbicide was applied to the water in June. OBSERVER PHOTO BY JASON STARR</p>



<p></p>



<h2>‘The effect has been profound’</h2>



<p>BY JASON STARR</p>



<p>Observer staff</p>



<p>It was just days after a chemical herbicide was applied to the north end of Lake Iroquois in Williston that the targeted invasive water weed, Eurasian milfoil, began to recede.</p>



<p>The treatment, sponsored by lakefront homeowners (the Lake Iroquois Association) and the municipal Lake Iroquois Recreation District, with representatives from each of the lake’s surrounding towns — Williston, Richmond, Hinesburg and St. George — took place June 28. By mid-July, milfoil, which for years had clogged the waters around the public beach and boat launch, was nearly eradicated, according to Lake Iroquois Association vice president Chris Conant. For the rest of the summer, boaters and swimmers were recreating like it was the 1980s, before the milfoil took hold, he said.</p>



<p>“The effect has been profound,” Lake Iroquois Association president Shannon Kelly said. Conant resides on the north end of the lake, near the Vermont Fish and Wildlife Department boat ramp and the Lake Iroquois Recreation District beach. He has heard positive feedback from users of both facilities.</p>



<p>“For the first time in a long time, you can take a kayak or a canoe and go out in the middle of that lake and look down and see the bottom of the lake,” said Conant. “We have not have that pleasure for many, many years, and it’s pretty amazing how awesome that looks.”</p>



<p>The association had tried other methods of milfoil eradication in years past, hiring divers to hand-pull the weed and placing mats on the lake bottom to cover it. A permit application with the Vermont Department of Environmental Conservation to use the chemical Sonar was denied in 2018 after a group of Hinesburg residents — with backing from the anti-chemical advocacy group the Toxics Action Center — flooded state regulators with concerns.</p>



<p>The state approved the association’s request to use the chemical Procellacor in Lake Iroquois in April, over the objections of the opposing Hinesburg residents.</p>



<p>A total of 20 gallons was poured into about 36 acres of the lake. The lake’s surface area totals about 245 acres. Signs around the lake advised against swimming for 24 hours after the chemical was applied. According to Conant, the chemical caused no lasting damage to any other plant species.</p>



<p>On Monday, a lake health specialist is scheduled to conduct a plant survey of the lake, raking up plant life from the bottom and determining what species are present. The survey is required by the association’s herbicide permit and Conant expects it to confirm the success of the herbicide treatment.</p>



<p>“It’s pretty amazing to have that much success with such a safe and minimal amount of chemical applied to the water,” he said. “This is a great step in the right direction. We feel really good about it. And we’re looking forward to getting the quality and health of the lake back to where it was 30 years ago.”</p>



<p>Conant hopes the association’s board of directors will agree to apply the chemical in another part of the lake next season. That would require an additional approval from the state Department of Environmental Conservation.</p>



<p>“We will eventually be doing another treatment at some point,” Conant said. “We have the rest of the lake to take care of. We can’t just do one end and not the other. It’s going to start all over again if we’re not careful.”</p>
				</div>
				<div class="entry-content clearfix">	
                    					
			        			    	
			    	
					
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.willistonobserver.com/red-sox-honor-benevento-posthumously/" rel="prev"><span> Previous Article</span> <p>Red Sox honor Benevento posthumously</p></a></div><div class="nav-next"><a href="https://www.willistonobserver.com/9-11-remembering-reflecting/" rel="next"><span> Next Article</span> <p>9/11: Remembering, reflecting</p></a></div></div>
	</nav>			</div><!-- .entry-content -->
            
			                    <div class="vmagazine-related-wrapper">
                <h4 class="related-title">
                    <span class="title-bg">Related Articles</span>
                </h4>
                <div class="related-posts-wrapper clearfix">                        <div class="single-post">
                                                        <div class="post-thumb">
                                <a href="https://www.willistonobserver.com/back-in-bloom/">
                                    <img src="https://www.willistonobserver.com/wp-content/uploads/2021/06/IMG_2792-510x369.jpg" alt="" title="Back in bloom" />
                                </a>
                                <span class="cat-links"><a href="https://www.willistonobserver.com/category/williston-vermont-news/" class="cat-3" rel="category tag">News</a></span>                            </div>
                                                        <div class="related-content-wrapper">
                                                                <div class="post-meta"><span class="posted-on"><i class="fa fa-clock-o"></i>June 10, 2021</span></div>
                                 <h3 class="small-font"><a href="https://www.willistonobserver.com/back-in-bloom/">Back in bloom</a></h3>
                                <div class="post-contents">
                                    The volunteers of Williston in Bloom have renewed their beautification campaign with flower plantings around Williston’s historic village district. Last week, members Sue Stanne, Pat Johnson and Molli 
                                </div>   
                                                                <a href="https://www.willistonobserver.com/back-in-bloom/" class="vmagazine-related-more">
                                    Read More                                </a>
                                                            </div>
                            
                        </div><!--. single-post -->
                                        <div class="single-post">
                                                        <div class="post-thumb">
                                <a href="https://www.willistonobserver.com/adjusting-to-a-new-kind-of-football/">
                                    <img src="https://www.willistonobserver.com/wp-content/uploads/2020/09/120018532_10158803424411730_2556844829956459937_o-2-510x369.jpg" alt="" title="Adjusting to a new kind of football" />
                                </a>
                                <span class="cat-links"><a href="https://www.willistonobserver.com/category/williston-vermont-news/" class="cat-3" rel="category tag">News</a></span>                            </div>
                                                        <div class="related-content-wrapper">
                                                                <div class="post-meta"><span class="posted-on"><i class="fa fa-clock-o"></i>September 24, 2020</span></div>
                                 <h3 class="small-font"><a href="https://www.willistonobserver.com/adjusting-to-a-new-kind-of-football/">Adjusting to a new kind of football</a></h3>
                                <div class="post-contents">
                                    Blocking and tackling are out, but the fun of the game remains By Lauren Read Observer correspondent Last season, Champlain Valley Union High School football player Isaac Bergeron would line up on the 
                                </div>   
                                                                <a href="https://www.willistonobserver.com/adjusting-to-a-new-kind-of-football/" class="vmagazine-related-more">
                                    Read More                                </a>
                                                            </div>
                            
                        </div><!--. single-post -->
                                        <div class="single-post">
                                                        <div class="post-thumb">
                                <a href="https://www.willistonobserver.com/trucks-meet-tradition-at-adams-farm-market/">
                                    <img src="https://www.willistonobserver.com/wp-content/uploads/2020/08/117542507_10158687333481730_1510167118281029291_o-510x369.jpg" alt="" title="Trucks meet tradition at Adams Farm Market" />
                                </a>
                                <span class="cat-links"><a href="https://www.willistonobserver.com/category/williston-vermont-news/" class="cat-3" rel="category tag">News</a></span>                            </div>
                                                        <div class="related-content-wrapper">
                                                                <div class="post-meta"><span class="posted-on"><i class="fa fa-clock-o"></i>August 16, 2020</span></div>
                                 <h3 class="small-font"><a href="https://www.willistonobserver.com/trucks-meet-tradition-at-adams-farm-market/">Trucks meet tradition at Adams Farm Market</a></h3>
                                <div class="post-contents">
                                    By Yasmin Tayeby Special to the Observer In the middle of a gravel parking lot lined with a colorful assortment of food trucks, a woman in a faded t-shirt and cargo shorts stands with her arms folded, 
                                </div>   
                                                                <a href="https://www.willistonobserver.com/trucks-meet-tradition-at-adams-farm-market/" class="vmagazine-related-more">
                                    Read More                                </a>
                                                            </div>
                            
                        </div><!--. single-post -->
                </div>                    </div><!-- .vmagazine-related-wrapper -->
                           
	<div id="respond" class="comment-respond">
		<h4 id="reply-title" class="comment-reply-title"><span class="title-bg">Comment here <small><a rel="nofollow" id="cancel-comment-reply-link" href="/herbicide-eases-milfoils-stranglehold-on-lake-iroquois/#respond" style="display:none;">Cancel reply</a></small></span></h4><p class="must-log-in">You must be <a href="https://www.willistonobserver.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.willistonobserver.com%2Fherbicide-eases-milfoils-stranglehold-on-lake-iroquois%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
					</article><!-- #post-## -->
			</main><!-- #main -->
</div><!-- #primary -->


<aside id="secondary" class="widget-area vmagazine-sidebar" role="complementary">
	<div class="theiaStickySidebar">
				<div class="widget willi-widget"><div data-advadstrackid="52647" data-advadstrackbid="1" data-advadsredirect="" class="willi-target" id="willi-1077229663"><a href="https://healthylivingmarket.com/store_location/williston/" rel="nofollow" class="adv-link" target="_blank"><img src="https://www.willistonobserver.com/wp-content/uploads/2021/06/HL_williston_observer_digital_300x250.jpg" alt="Healthy Living Market &amp; Cafe Now Open in Williston"  width="300" height="250"   /></a></div></div><div class="widget willi-widget"><div data-advadstrackid="52622" data-advadstrackbid="1" data-advadsredirect="" class="willi-target" id="willi-907992380"><a href="https://willistoncoffeeshop.com" rel="nofollow" class="adv-link" target="_blank"><img src="https://www.willistonobserver.com/wp-content/uploads/2021/06/WCS-Web.jpg" alt=""  width="300" height="255"   /></a></div></div><div class="widget willi-widget"><div data-advadstrackid="52946" data-advadstrackbid="1" data-advadsredirect="" class="willi-target" id="willi-1540981395"><a href="https://www.alfreyphotography.com" rel="nofollow" class="adv-link" target="_blank"><img src="https://www.willistonobserver.com/wp-content/uploads/2021/09/AlFrey-300x300-WebAd.jpeg" alt=""  width="300" height="300"   /></a></div></div>			</div>
</aside><!-- #secondary -->
</div></div><!-- #content -->

			
		<footer id="colophon" class="site-footer footer-three">

				<div class="buttom-footer footer_one">
			<div class="footer-btm-wrap">
			<div class="vmagazine-container">
				<div class="vmagazine-btm-ftr">
					<div class="footer-credit">
	            						<div class="site-info">
											© 2021 Williston Observer
	
									</div><!-- .site-info -->				
			            	</div>
	            	        		</div>
            </div>
		</div>
</div>
		
			
		</footer><!-- #colophon -->
		
	
<a href="#" class="scrollup">
	<i class="fa fa-angle-up" aria-hidden="true"></i>
</a>
</div><!-- .vmagazine-main-wrapper -->

<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/lazy-load/jquery.lazy.min.js?ver=1.1.8' id='jquery-lazy-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/mCustomScrollbar/jquery.mCustomScrollbar.js?ver=1.1.8' id='jquery-mCustomScrollbar-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/js/jquery.fitvids.js?ver=1.1.8' id='jquery-fitvids-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/js/navigation.js?ver=1.1.8' id='vmagazine-navigation-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/js/skip-link-focus-fix.js?ver=1.1.8' id='vmagazine-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/lightslider/lightslider.js?ver=1.1.8' id='jquery-lightslider-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/js/wow.js?ver=1.1.8' id='jquery-wow-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/prettyPhoto/js/jquery.prettyPhoto.js?ver=1.1.8' id='jquery-prettyphoto-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/js/iframe-api.js?ver=1.1.8' id='youtube-api-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/theia-sticky-sidebar/theia-sticky-sidebar.js?ver=1.1.8' id='jquery-theia-sticky-sidebar-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/library/slick/slick.min.js?ver=1.1.8' id='jquery-slick-js'></script>
<script type='text/javascript' id='vmagazine-custom-script-js-extra'>
/* <![CDATA[ */
var vmagazine_ajax_script = {"mode":"enable","ajax_search":"show","ajaxurl":"https:\/\/www.willistonobserver.com\/wp-admin\/admin-ajax.php","fileUrl":"https:\/\/www.willistonobserver.com\/wp-content\/themes\/vmagazine","lazy":"enable","controls":"1","rtl":"false","preloader":"hide","stickyHeader":"show"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/themes/vmagazine/assets/js/vmagazine-custom.js?ver=1.1.8' id='vmagazine-custom-script-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-includes/js/comment-reply.min.js?ver=5.7.3' id='comment-reply-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"willi-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.0.1' id='advadsTrackingScript-js'></script>
<script type='text/javascript' src='https://www.willistonobserver.com/wp-includes/js/wp-embed.min.js?ver=5.7.3' id='wp-embed-js'></script>
<script>window.advads_has_ads = [["52647","ad",null],["52622","ad",null],["52946","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><script>var advads_tracking_ads = {"1":[52647,52622,52946]};var advads_tracking_urls = {"1":"https:\/\/www.willistonobserver.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"onrequest"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/www.willistonobserver.com\/linkout\/"};</script>


</body>
</html>

<!-- Dynamic page generated in 0.202 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-09-09 19:57:30 -->

<!-- Compression = gzip -->